Gallery2:2.2.2 Change Candidates - Gallery Codex
Personal tools

Gallery2:2.2.2 Change Candidates

From Gallery Codex

Revision as of 09:37, 8 April 2007 by Talmdal (Talk | contribs)

If we release a Gallery 2.2.2, the following changes should be considered to be included.

r16188 - Fix core upgrade notification in template

Fix core upgrade notification in template

An incorrect variable name (which, sadly we don't get a warning for from Smarty) causes us to fail to see the notification that there's a newer version of the core available. And a quick review of the text shows that one of the bullet points is confusing/unhelpful so I removed it.

r16216 - Fatal PHP error in fetchWebPage on too many redirects

Fix for bug 1693499 - Fatal PHP error in fetchWebPage on too many redirects. Was introduced in r15375 (in G2.2).

r16225 - Fix rewrite rule for embedded core.DownloadItem

Fix for bug 1693956. The core.DownloadItem RewriteRule had a wrong rewrite target URL, it included the sessionId from configuration time. This could well break an embedded G2.2 (losing the session, not seeing non-public content, etc).

r16237 - Uninstall warning

Fix for bug 1695294. Need stronger warning when uninstalling plugins.

r16263 - Session Data Truncated

Fix for bug 1593803. Session data could be truncated on large imports from g1 with lots of data.