Gallery2:Installation Requirements - Gallery Codex
Personal tools

Gallery2:Installation Requirements

From Gallery Codex

Revision as of 21:18, 11 July 2010 by Floridave (Talk | contribs) (ffmpeg)

Gallery has certain technical requirements that must be met (i.e. installed and/or configured) on your server before you attempt to install it.

Web Server

Apache

Apache (Apache 1, Apache 2) is the most popular web server in the world, and is the one recommended by the Gallery Team for use with Gallery 2. It can be downloaded from the Apache HTTPD Project's site

IIS

Microsoft's IIS (Internet Information Services) web server has also been known to work. But there are some limitations. See Known Issues for details. Short URLs work, but G1 redirects are not yet supported for IIS. Also take a look at our Windows Server 2003 and IIS 6 Howto.

Zeus, ...

There are a lot of alternative web servers. G2 should work on any web server that can run PHP. But short URLs / G1 redirects (URL rewrite module) probably do not work with all of them.

PHP

Gallery is written in PHP (recursive acronym for PHP: Hypertext Preprocessor). It is one of the most popular, free web-based languages in the world today. It can also be downloaded gratis from the PHP Project's site.

PHP Version Compatibility

Gallery requires at least version 4.x (4.3.0 or more recent) or 5.x (5.0.4 or more recent) to function properly. Note: Gallery 2 has problems with PHP 5.0.5 due to a bug in PHP .

Notes:
  • PHP 5 is highly recommended - PHP will not release any security updates for PHP 4 after 2008/08/08. If your webhost is still running PHP 4, please ask them to switch to PHP 5 as soon as possible for security reasons (not just for Gallery, but for all PHP applications).
  • Only Gallery 2.3.1 supports PHP 5.3. PHP 5.3 is incompatible with Gallery 2.0 - 2.3.
  • PHP 6 is incompatible with Gallery 2.0 - 2.3; not yet tested with Gallery 2.3.1

PHP Settings

In addition to a basic PHP installation, Gallery requires certain PHP settings to be setup correctly in order to function optimally.

PHP settings can be changed in php.ini, as described in the PHP documentation

  • safe_mode safe_mode must be disabled in order for Gallery to work correctly
    • for a in depth discussion on safe mode please read this forum thread.
  • disable_functions The disable_functions directive must not include the function set_time_limit.
  • file_uploads file_uploads must be set to On if Gallery is to be able to upload files from your computer
  • upload_max_filesize and post_max_size These configuration parameters control the maximum file size that can be uploaded. Adjust these from the default 2M setting to something larger if you have problems uploading pictures from higher resolution cameras.
  • If you want to use the localization feature then PHP should be configured with the gettext option enabled.

alindeman has created a script to check your Gallery for potential problems due to PHP settings. Download the script and upload it to your host. Open the script in your browser (http://www.example.com/gallery/ghcc.php). If any tests fail, you may need to adjust your settings before trying to install Gallery.

Database

Gallery 2 requires one of the following database management systems (DBMS): MySQL 3.x or 4.x, 5.x, PostgreSQL 7.x, 8.x, Oracle 9i or 10g, IBM DB2 8.2, Microsoft SQL Server

Note: MS SQL Server has only limited support for international characters (unicode). Read more at Limitations of Microsoft SQL Server

Additional RDBMS specific notes:

Image Processing Library

Gallery 2 requires either NetPBM 9.x or newer, ImageMagick 4.x or newer, GD 2.x or newer, or GraphicsMagick 1.x or newer in order to operate (e.g. generate thumbnails) on your images and photographs.

More information on how to install an image processing library is explained on Installing an Image Processing Library

Optional Items

mod_rewrite

mod_rewrite is an Apache server extension that enables your Gallery 2 to use "short URLs." That is, instead of

 http://www.example.com/gallery/main.php?g2_view=core.ShowItem&g2_itemId=17&g2_serialId=2

the URL would be reduced to

 http://www.example.com/gallery/v/albumName

Gallery 2 will attempt to automatically check for the presence of mod_rewrite during the installation process if you select the URL rewrite module.

ffmpeg

If the Ffmpeg module is activated, it will automatically create thumbnails for movies. The ffmpeg module requires the ffmpeg binary. If you have shell access to the server, you can install ffmpeg with the packaging system of your linux distribution.

  • Dreamhost directions (should be similar to most hosts.

Windows:

Other OSs:

Mac OS: If you are using Gallery2 on Mac OS X, then you need to read the steps on this wiki page to get/install ffmpeg and configure the ffmpeg Gallery2 module.

dcraw

Dcraw is a graphics toolkit that can be used to process RAW images produced by high end digital cameras. You must install the dcraw binary to activate the dcraw module in G2.

jhead

jhead is a free tool that can be used to extract EXIF data from images, which most digital cameras now add to photos. If enabled, EXIF data will be preserved when operating with the netpbm toolkit on your original photos in G2. You don't need jhead for the EXIF features in G2, a library written in PHP is used to extract the EXIF data from images. Imagemagick and GD don't need jhead to preserve the exif data when manipulating images.

infozip

infozip is a free tool that allows Gallery to unzip ZIP archives so that you can easily upload multiple photos. If enabled, you will be able to upload a ZIP archive as you would any other single picture, and Gallery will add all the images in the archive.

zip / unzip

zip is required for the zip download module and unzip for the archive upload module. Most linux / unix based platforms already have these binaries. For MS Windows, the zip.exe / unzip.exe binaries from cygwin are also an alternative, make sure you select the zip tool under archive during the install (it will not install by default), it is located in /bin/.

advertisements