Difference between revisions of "Talk:Schultmc" - Gallery Codex
Personal tools

Difference between revisions of "Talk:Schultmc"

From Gallery Codex

(Things to fix for debian and G2)
 
(9 intermediate revisions by 3 users not shown)
Line 5: Line 5:
 
:* Detect if the mysql (or postgres) database already exists and give an error
 
:* Detect if the mysql (or postgres) database already exists and give an error
 
:* Create the databases in UNICODE if possible
 
:* Create the databases in UNICODE if possible
:* Add a dependency on the UTF-8 locale
+
:* Add a dependency on the UTF-8 locale, or make the postinstaller provide installing utf8 as an option.  (grep /etc/locale.gen, etc)
:* Recommend mysql-server or postgresql-server
+
:* Edit default apache.conf (should say gallery2, not gallery)
 +
 
 +
==Missing Dependencies==
 +
:* php4-mysql|php4-pgsql
 +
 
 +
==Missing Recommends==
 +
 
 +
:* mysql-server|mysql-server-4.1
 +
:* postgresql-7.4|postgresql-8.0

Latest revision as of 10:56, 12 September 2005

Things to fix for debian and G2

  • add 32MB php memory limit in gallery2/.htaccess (php_value memory_limit 32M) -- unless they already have a higher limit. Don't lower it if it's higher. (grep php.ini and parse the memory limit)
  • Add support for postgres also (both in the dialogs and the dependencies)
  • Detect if the mysql (or postgres) database already exists and give an error
  • Create the databases in UNICODE if possible
  • Add a dependency on the UTF-8 locale, or make the postinstaller provide installing utf8 as an option. (grep /etc/locale.gen, etc)
  • Edit default apache.conf (should say gallery2, not gallery)

Missing Dependencies

  • php4-mysql|php4-pgsql

Missing Recommends

  • mysql-server|mysql-server-4.1
  • postgresql-7.4|postgresql-8.0
advertisements